Author Topic: BFEing the chassis works fine in Bot Lab, doesn't in Testing  (Read 356 times)

Offline Manic_Eraser_Cat

  • Antweight
  • Posts: 7
  • Rep: 0
  • Arrivederci
    • View Profile
    • Awards
  • Discord: Manic_Eraser_Cat#8767
DSL 2.2 - Good Robottal's 2018 Battlebots Pack
When I BFEd a chassis, it worked fine and in the bot lab, it displayed correctly. However in the testing arena, not only did the BFE not make a difference to its appearance, but the mesh acted as if the chassis was tweaked, like in the bot lab.

 

 
« Last Edit: July 05, 2019, 01:41:28 PM by Hoppin »
Killer Bean - Daiichi no Bakudan
Killer Bean - Daini no Bakudan: Garbanzo Heart Attack
Killer Bean - Daisan no Bakudan: Borlotti the Dust

Offline F1Krazy

  • Team VVV - Veni Vidi Vici
  • Heavyweight
  • Posts: 791
  • Rep: 4
  • Nothing is easy the first time round
    • View Profile
    • Awards
  • See profile for gamer tags: Yes
Re: BFEing the chassis works fine in Bot Lab, doesn't in Testing
« Reply #1 on: June 30, 2019, 04:08:45 AM »
This actually happens to me as well, and has been happening for a while, so I'd be interested to know the solution.
My DSL Showcase


Offline Badnik96

  • tired of your shit
  • *
  • Posts: 17628
  • Rep: 4
    • Badnik96GTM
  • Awards BOTM Winner
    • View Profile
    • BattleBots Wiki
    • Awards
  • See profile for gamer tags: Yes
  • Skype: Badnik96
Re: BFEing the chassis works fine in Bot Lab, doesn't in Testing
« Reply #2 on: July 03, 2019, 10:36:55 PM »
the bot file contains two meshes, one for the bot lab and one for the collisions in combat. you need to edit both

Offline Manic_Eraser_Cat

  • Antweight
  • Posts: 7
  • Rep: 0
  • Arrivederci
    • View Profile
    • Awards
  • Discord: Manic_Eraser_Cat#8767
Re: BFEing the chassis works fine in Bot Lab, doesn't in Testing
« Reply #3 on: July 07, 2019, 06:56:33 PM »
Do you know where this second mesh is? There are only 3 instances where I find the coordinates of a point, which represents the 3 meshes a single point has.
Killer Bean - Daiichi no Bakudan
Killer Bean - Daini no Bakudan: Garbanzo Heart Attack
Killer Bean - Daisan no Bakudan: Borlotti the Dust

Offline [cringey name goes here]

  • Chicken Nugget Enthusiast
  • Heavyweight
  • Posts: 542
  • Rep: -4
  • [relevant meme]
    • View Profile
    • Awards
Re: BFEing the chassis works fine in Bot Lab, doesn't in Testing
« Reply #4 on: July 07, 2019, 08:13:34 PM »
Do you know where this second mesh is? There are only 3 instances where I find the coordinates of a point, which represents the 3 meshes a single point has.
you should be able to do ctrl+f and replace all results
please eat something that you're allergic to, in excessive ammounts

Offline Manic_Eraser_Cat

  • Antweight
  • Posts: 7
  • Rep: 0
  • Arrivederci
    • View Profile
    • Awards
  • Discord: Manic_Eraser_Cat#8767
Re: BFEing the chassis works fine in Bot Lab, doesn't in Testing
« Reply #5 on: July 07, 2019, 08:55:52 PM »
That's what I've been doing, but there are only 3 things that match the coordinates in the bot file, and replacing all makes no difference
Killer Bean - Daiichi no Bakudan
Killer Bean - Daini no Bakudan: Garbanzo Heart Attack
Killer Bean - Daisan no Bakudan: Borlotti the Dust

Offline kix

  • Obeseweight
  • *
  • Posts: 2747
  • Rep: 12
  • ENTER BOTM
    • View Profile
    • Awards
  • Discord: Username#8552
Re: BFEing the chassis works fine in Bot Lab, doesn't in Testing
« Reply #6 on: July 08, 2019, 08:18:48 AM »
Graphic options set to low?

the bot file contains two meshes, one for the bot lab and one for the collisions in combat. you need to edit both
Not sure if thats true. If it is, ill have to add this in my guids
ENTER BOTM OR I WILL

Offline Resetti's Replicas

  • *
  • Posts: 4392
  • Rep: 17
  • Replica King
    • ResettisReplicas
  • Awards BOTM Winner
    • View Profile
    • Awards
  • See profile for gamer tags: Yes
Re: BFEing the chassis works fine in Bot Lab, doesn't in Testing
« Reply #7 on: July 08, 2019, 08:28:03 AM »
Try setting your graphics quality to Low.  If you have it on Med or High, it will show changes to the main height (ie Y-value at the very top of the Bot File)  but nothing else.

Offline Manic_Eraser_Cat

  • Antweight
  • Posts: 7
  • Rep: 0
  • Arrivederci
    • View Profile
    • Awards
  • Discord: Manic_Eraser_Cat#8767
Re: BFEing the chassis works fine in Bot Lab, doesn't in Testing
« Reply #8 on: July 08, 2019, 11:11:19 AM »
Thanks, I had it set on medium, and setting it to low fixed it easily.
Killer Bean - Daiichi no Bakudan
Killer Bean - Daini no Bakudan: Garbanzo Heart Attack
Killer Bean - Daisan no Bakudan: Borlotti the Dust